Error with composer using Laravel for JWT

  composer-php, jwt, laravel, php

following this guide: I’ve installed tymon/jwt-auth:^[email protected] correctly. It’s all okay but, when I run: composer require irazasyed/jwt-auth-guard, this error appears.

composer require irazasyed/jwt-auth-guard
Using version ^1.0 for irazasyed/jwt-auth-guard
./composer.json has been updated
Running composer update irazasyed/jwt-auth-guard
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - irazasyed/jwt-auth-guard[dev-master, v1.0.0, ..., v1.0.4] require illuminate/support ~5.0 -> found illuminate/support[v5.0.0, ..., 5.8.x-dev] but these were not loaded, likely because it conflicts with another require.
    - irazasyed/jwt-auth-guard 1.0.x-dev is an alias of irazasyed/jwt-auth-guard dev-master and thus requires it to be installed too.
    - Root composer.json requires irazasyed/jwt-auth-guard ^1.0 -> satisfiable by irazasyed/jwt-auth-guard[v1.0.0, ..., 1.0.x-dev (alias of dev-master)].

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

My PHP version is: 7.4.16;

My Laravel version is: 8.12;

My composer version is: 2.0.9.

I don’t know what can I do. Thanks to all for the help!

Source: Ask PHP