compile error during composer install symfony

  composer-php, laminas, php, symfony

I’m trying to move a project from an old server on a new. Not same version of PHP. and I have trouble when I do a composer install…
this is the composer.json

{
"name": "symfony/framework-standard-edition",
"license": "MIT",
"type": "project",
"description": "The "Symfony Standard Edition" distribution",
"autoload": {
    "psr-0": { "Mda": "src/", "SymfonyStandard": "app/" },
    "files": ["app/AppKernel.php"]
},
"require": {
    "php": ">=5.6",
    "symfony/symfony": "3.4.*",
    "doctrine/orm": "~2.5",
    "doctrine/doctrine-bundle": "~1.5",
    "twig/extensions": "~1.2",
    "symfony/assetic-bundle": "~2.7",
    "symfony/swiftmailer-bundle": "~2.3",
    "symfony/monolog-bundle": "~3.2.0",
    "sensio/distribution-bundle": "~5.0",
    "sensio/framework-extra-bundle": "~3.0",
    "incenteev/composer-parameter-handler": "~2.1",
    "friendsofsymfony/user-bundle": "~2.0",
    "friendsofsymfony/jsrouting-bundle": "~1.5",
    "knplabs/knp-snappy-bundle": "1.4.*",
    "zendframework/zend-code": "~3.4",
    "guzzlehttp/guzzle": "~6.2",
    "itbz/fpdf": "1.7.2",
    "stfalcon/tinymce-bundle": "~2.0",
    "webnet/swissarmy-bundle": "1.0.x-dev",
    "friendsofsymfony/rest-bundle": "2.0.x-dev",
    "jms/serializer-bundle": "^2.4.2",
    "mikehaertl/php-pdftk": "^0.4.4",
    "beberlei/doctrineextensions": "^1.0",
    "doctrine/doctrine-migrations-bundle": "^1.0"
},
"require-dev": {
    "sensio/generator-bundle": "~3.1"
},
"scripts": {
    "post-root-package-install": [
        "SymfonyStandardComposer::hookRootPackageInstall"
    ],
    "post-install-cmd": [
        "IncenteevParameterHandlerScriptHandler::buildParameters",
        "SensioBundleDistributionBundleComposerScriptHandler::buildBootstrap",
        "SensioBundleDistributionBundleComposerScriptHandler::clearCache",
        "SensioBundleDistributionBundleComposerScriptHandler::installAssets",
        "SensioBundleDistributionBundleComposerScriptHandler::installRequirementsFile",
        "SensioBundleDistributionBundleComposerScriptHandler::removeSymfonyStandardFiles"
    ],
    "post-update-cmd": [
        "IncenteevParameterHandlerScriptHandler::buildParameters",
        "SensioBundleDistributionBundleComposerScriptHandler::buildBootstrap",
        "SensioBundleDistributionBundleComposerScriptHandler::clearCache",
        "SensioBundleDistributionBundleComposerScriptHandler::installAssets",
        "SensioBundleDistributionBundleComposerScriptHandler::installRequirementsFile",
        "SensioBundleDistributionBundleComposerScriptHandler::removeSymfonyStandardFiles"
    ]
},
"config": {
    "secure-http": false
},
"extra": {
    "symfony-app-dir": "app",
    "symfony-web-dir": "web",
    "symfony-var-dir": "var",
    "symfony-bin-dir": "bin",
    "symfony-assets-install": "relative",
    "incenteev-parameters": {
        "file": "app/config/parameters.yml"
    },
    "branch-alias": {
        "dev-master": "2.6-dev"
    }
},
"repositories": [
    {
        "type": "svn",
        "url": "https://bellatrix.webnet.fr/WebnetSwissArmyBundle"
    }
]

}

and the error is

 PHP Fatal error:  Could not check compatibility between SymfonyBridgeProxyManagerLazyProxyPhpDumperLazyLoadingValueHolderGenerator::generate(ReflectionClass $originalClass,

ZendCodeGeneratorClassGenerator $classGenerator) and ProxyManagerProxyGeneratorLazyLoadingValueHolderGenerator::generate(ReflectionClass $originalClass, LaminasCodeGener
atorClassGenerator $classGenerator), because class ZendCodeGeneratorClassGenerator is not available in /var/www/mda/vendor/symfony/symfony/src/Symfony/Bridge/ProxyManager/La
zyProxy/PhpDumper/LazyLoadingValueHolderGenerator.php on line 25

In LazyLoadingValueHolderGenerator.php line 25:

Compile Error: Could not check compatibility between SymfonyBridgeProxyMa
nagerLazyProxyPhpDumperLazyLoadingValueHolderGenerator::generate(Reflect
ionClass $originalClass, ZendCodeGeneratorClassGenerator $classGenerator
) and ProxyManagerProxyGeneratorLazyLoadingValueHolderGenerator::generate
(ReflectionClass $originalClass, LaminasCodeGeneratorClassGenerator $cla
ssGenerator), because class ZendCodeGeneratorClassGenerator is not avail
able

have you an idea? Thanks

Source: Ask PHP

LEAVE A COMMENT